Volkswagen Golf MKIVolkswagen Golf MKIIVolkswagen Golf MKIIIVolkswagen Golf MKIVVolkswagen Golf MKVVolkswagen Golf MKVIVolkswagen Golf MKVII


+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Speedometer on MK3

  1. #1
    Senior Member Kooki's Avatar
    Join Date
    Mar 2010
    Location
    Sydney
    Daily
    MK3 GL Manual
    Name
    Angela
    Posts
    214

    Speedometer on MK3

    Today my speedometer stopped working. The needle is stuck at 0 kms. Is there a DIY on how to fix this? Does it need to get replaced? How big a job is it to replace?
    Is it an offence to drive a car with speedometer that's not working. I will now be guessing am I under the speed limit or over the speed limit. Oh well maybe I can enjoy driving without checking the speedometer all the time.

  2. #2
    Junior Member URUS's Avatar
    Join Date
    Nov 2010
    Daily
    Golf 3 1.8 GL manual
    Posts
    2

    It is not an offence,but u should fix it in any way=)

  3. #3
    Senior Member Kooki's Avatar
    Join Date
    Mar 2010
    Location
    Sydney
    Daily
    MK3 GL Manual
    Name
    Angela
    Posts
    214

    Thanks Urus, I found out it is a cable that needs to be replaced. Probably have to take out the dash??

  4. #4
    Junior Member URUS's Avatar
    Join Date
    Nov 2010
    Daily
    Golf 3 1.8 GL manual
    Posts
    2

    U r welcome=)If it is a cable u have to take out the dash anyway.

  5. #5
    Senior Member vdubin's Avatar
    Join Date
    Apr 2010
    Location
    Albury
    Posts
    311

    Sounds like a fun job...,good luck!

  6. #6
    Senior Member Kooki's Avatar
    Join Date
    Mar 2010
    Location
    Sydney
    Daily
    MK3 GL Manual
    Name
    Angela
    Posts
    214

    The other day it started working again and then stopped. Going to try and disconnect the battery maybe it will reset itself like when you restart PC. Sounds silly but worth a try!

  7. #7
    Senior Member rayray086's Avatar
    Join Date
    Feb 2010
    Location
    Merrylands, Sydney
    Daily
    8L A3T
    Posts
    791

    Is it just the speedo that's not working or other gauges too? The first time it happened to me it was the speed sensor at the gearbox. Only my speedo and odo didn't work. Second time round it was my dash cluster - my speedo worked intermittently before failing completely along with the fuel gauge and tacho.
    Past: Mk3 Golf 2.0L 8V RIP
    Present: Audi 8L A3T

  8. #8
    Senior Member Kooki's Avatar
    Join Date
    Mar 2010
    Location
    Sydney
    Daily
    MK3 GL Manual
    Name
    Angela
    Posts
    214

    Everything is working except the speedo and rev's

  9. #9
    Junior Member
    Join Date
    Feb 2013
    Location
    Sydney
    Daily
    VW Golf 2002 1.6L
    Name
    Jim
    Posts
    4

    So did you fix your speedo now? Mine stopped as well, other things are working fine. WOuld be awesome if you share what to do? Thanks

  10. #10
    Junior Member
    Join Date
    Apr 2013
    Location
    Brisbane
    Daily
    VW Golf MK3
    Posts
    2

    Hey guys, I'm new to the site and just bought a Vw golf Mk3. It has the same problem with the speedo, i've noticed there's a few sites with people complaining about the same thing. It seems to work when I first start the car, then when I jump back in the car it's stopped working. I spent this evening pulling out the dash and having a play with it, everything looks fine and in working order. Someone suggested that it's possibly the solder on the circuits overheating, making the signal scatter. But all the other gauges are working... Not sure.?? I will spend the day tomorrow pulling it apart again and will inform you if I find out what the cause is. For now i'm just using the speedo on my GPS to get me around! lol.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts