Volkswagen Golf MKIVolkswagen Golf MKIIVolkswagen Golf MKIIIVolkswagen Golf MKIVVolkswagen Golf MKVVolkswagen Golf MKVIVolkswagen Golf MKVII


+ Reply to Thread
Results 1 to 3 of 3

Thread: golf tdi mk5 bkd 2.0

  1. #1
    Junior Member
    Join Date
    Jan 2017
    Location
    erina
    Daily
    sv6 ute
    2nd Car
    golf tdi mk5
    Name
    allan
    Posts
    9

    golf tdi mk5 bkd 2.0

    so the golf i was going into limp mode . removed turbo and cleaned out fully after a p0234 code .
    i then to it to the local euro mechanics and had vagcom run these wer the results .
    p234 bppst pressure regulation control limit exceeded
    p234 turbo boost sensor A curcuit high input
    p1495 radiater exhaust gas recirculation switch over valve n345
    p1440 egr vacumn regulater solenoid valve open circuit
    p243 turbo wastegate solenoid A sporadic
    p102 mass air flow circuit
    p113 intake air temp sensor 1 bank 1
    all codes were cleared then test drove , rescanned and p102 mass air flow circuit was was the only fault that has returned .

    the mechanics were very busy and could not explain the codes to me at the time .
    could this possibly due to bad earth wiring ? or should i start replacing all the sensors ?


    any imput from you tdi gurus would be much appreciated .

  2. #2
    Member mek's Avatar
    Join Date
    Aug 2015
    Location
    OCE
    Daily
    Driftspec GTI
    2nd Car
    Rallyspec R
    Name
    Trackspec 32
    Posts
    69

    def sounds like wiring to me- maybe replace the MAF , and yeah it could be bad earthing or just old wires- bit of a tricky fix.

    id look into replacing sensors if its cheap. :P

    Glad you cleaned out the turbo tho! what did you use to clean it?

  3. #3
    Junior Member
    Join Date
    Jan 2017
    Location
    erina
    Daily
    sv6 ute
    2nd Car
    golf tdi mk5
    Name
    allan
    Posts
    9

    thanks for reply mek , removed turbo stripped down and cleaned with brake cleaner . all working well had all error codes removed which apparently were old errors so i was told by mechanic then he test drove it again , the only fault that popped back up was maf airflow circuit p 102. cleaned the sensor with a light degreaser but looked quite clean anyway . checked wiring and had 11.98 v at power terminal and increasing power at sender terminal . still going into limp mode . not sure if tdi is like fuel engine where you unplug maf and if it goes like a rocket the maf is usually the problem .

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts