Volkswagen Golf MKIVolkswagen Golf MKIIVolkswagen Golf MKIIIVolkswagen Golf MKIVVolkswagen Golf MKVVolkswagen Golf MKVIVolkswagen Golf MKVII


+ Reply to Thread
Results 1 to 6 of 6

Thread: RNS510 not remembering presets - audio steering wheel controls not working

  1. #1
    Senior Member Milos504's Avatar
    Join Date
    Mar 2014
    Location
    ACT
    Daily
    2007 MK 5 GTI
    Posts
    201

    RNS510 not remembering presets - audio steering wheel controls not working

    Hey guys

    Recently my RNS510 lost all radio presets and the audio steering wheel controls stopped working. Radio still works fine, but if I save a station and restart the car the preset is lost. The steering wheel controls started working every now and then.

    Car is 2012, mk6 R and I have scanned it with vagcom - no errors come up.

    Has anyone experienced a similar issue? if so what could fix the problem?
    GOLF 6 R - APR stage 1

  2. #2
    Junior Member
    Join Date
    May 2010
    Location
    Sydney
    Daily
    Golf GTI mk6
    Posts
    5

    Hi Milos,

    I haven't had the same issues, but you could try a firmware update on the RNS as a first attempt?

  3. #3
    Senior Member Milos504's Avatar
    Join Date
    Mar 2014
    Location
    ACT
    Daily
    2007 MK 5 GTI
    Posts
    201

    Quote Originally Posted by leopoldbutterstotch View Post
    Hi Milos,

    I haven't had the same issues, but you could try a firmware update on the RNS as a first attempt?
    I thought of that but I'm scared of losing the maps and all the other stuff, reverse camera, blue tooth all that.. That would need coding and installation I'm assuming... I thought I'd ask here to see if anyone had similar issue before.
    GOLF 6 R - APR stage 1

  4. #4
    Junior Member
    Join Date
    May 2010
    Location
    Sydney
    Daily
    Golf GTI mk6
    Posts
    5

    Fair enough Milos, I had problems similar to the "Regensburg Syndrome" publicised on the internet... so bit the bullet and went ahead to reinstall the firmware and maps. Admittedly I was a little reluctant at first also... but it has fixed the problem. Unfortunately it takes a bit of mucking around downloading firmware, maps as well as coding to enable steering when controls again. Fortunately for me everything else (reverse camera and Bluetooth) worked with no dramas.

    Sorry I cannot be of more help... hope there is someone out there who has experienced similar issues who are able to offer more assistance.

    Good luck!

  5. #5
    Senior Member Milos504's Avatar
    Join Date
    Mar 2014
    Location
    ACT
    Daily
    2007 MK 5 GTI
    Posts
    201

    Quote Originally Posted by leopoldbutterstotch View Post
    Fair enough Milos, I had problems similar to the "Regensburg Syndrome" publicised on the internet... so bit the bullet and went ahead to reinstall the firmware and maps. Admittedly I was a little reluctant at first also... but it has fixed the problem. Unfortunately it takes a bit of mucking around downloading firmware, maps as well as coding to enable steering when controls again. Fortunately for me everything else (reverse camera and Bluetooth) worked with no dramas.

    Sorry I cannot be of more help... hope there is someone out there who has experienced similar issues who are able to offer more assistance.

    Good luck!
    Thanks mate. My mechanic can update the firmware and maps for me, as well as check wiring, so I'll probably book it in with them to get it fixed.
    GOLF 6 R - APR stage 1

  6. #6
    Senior Member Milos504's Avatar
    Join Date
    Mar 2014
    Location
    ACT
    Daily
    2007 MK 5 GTI
    Posts
    201

    Quick update to this. I've updated the firmware and everything is working fine now.
    GOLF 6 R - APR stage 1

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts